Libera EPICS Drivers

The following releases provide EPICS support for the Libera Electron beam position monitor. For details on Libera see the Instrumentation Technologies web site.

Release Notes

For detailed changes see CHANGES. For a detailed description of the functionality in the current release see Libera Documentation.

Contact

contact

Releases

Comments iconInstall iconSource

This is a maintenance release with a number of minor new features and some installation bug fixes. At the time of writing this release is not fully tested.

iconInstall 2.05.7 icon2.05.7

This is a minor update to 2.05.2, see CHANGES for details. The documentation is improved in this release and some waveform statistics are calculated.

Note: There is a bug in the installation script when installing on a standard Libera Electron, the instrument type can be incorrectly detected. To avoid this problem please use the -TELECTRON option with libera-install-ioc, but ONLY when installing on an Electron instrument.

iconInstall 2.05.3 icon2.05.3

This is a minor update to 2.05. This release has been in operational use at Diamond since January 2010.

iconInstall 2.05.2 icon2.05.2

This is a minor update to 2.00.0, see CHANGES for details. The documentation has been updated for this release.

iconInstall 2.05 icon2.05

This is compatible with all Libera releases from 1.46 onwards, including 1.46, 1.60, 1.82, 2.00 to 2.05 on both Brilliance and Electron. This release was in operational use at Diamond from July 2009 until January 2010.

iconInstall 2.00.0 icon2.00.0

This should be compatible with all current Libera releases: 1.46, 1.60, 1.82, plus Brilliance.

iconInstall 1.46.4.2
iconlibstdc++.so.6
icon1.46.4.2

The last Source Forge release, compatible with Libera 1.46 but not Brilliance.

icon1.46.1

This is the last Libera EPICS driver release which works with Libera 1.40 and 1.42.

icon1.40.2

Some older releases can be found at Source Forge, but all future releases will be made here.